PAT甲级:A1029 Median (25分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

1
2
4 11 12 13 14
5 9 10 15 16 17

Sample Output:

1
13
  • 题意:给出两个递增序列,找出两个序列合并后的中位数。
  • 分析:如果真的合并两个序列,重新排序再取中值,那么必然会超时的。先计算出中值的位置pos两序列的大小之和加 1 后再除以2),因为两个序列都是有序的,所以从两个序列的第一个元素开始比较,声明变量ij分别用以遍历a、b序列,比较当前元素,谁更小就把谁的指针向后移动,同时用cnt计数,当 cnt == pos 时退出,如果没找到,则到未遍历完的序列去找。
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    #include <bits/stdc++.h>
    using namespace std;
    int main() {
    int n;
    scanf("%d", &n);
    vector<int> a(n);
    for (int i = 0; i < n; i++) scanf("%d", &a[i]);
    scanf("%d", &n);
    vector<int> b(n);
    for (int i = 0; i < n; i++) scanf("%d", &b[i]);
    int pos = (a.size() + b.size() + 1) / 2, i = 0, j = 0, cnt = 0, ans;
    while (i < a.size() && j < b.size()) {
    ans = a[i] <= b[j] ? a[i++] : b[j++];
    if (++cnt == pos) break;
    }
    for (; i < a.size() && cnt != pos; i++, cnt++) ans = a[i];
    for (; j < b.size() && cnt != pos; j++, cnt++) ans = b[j];
    printf("%d", ans);
    return 0;
    }