PAT甲级:A1028 List Sorting (25分)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

1
2
3
4
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

1
2
3
000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

1
2
3
4
5
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

1
2
3
4
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

1
2
3
4
5
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

1
2
3
4
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
  • 题意:根据要求排序。当C=1时,按学号递增排序;当C=2时,按姓名的非递减字典序排序;当C=3时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。
  • 分析:题意简单明了,定义一个全局变量c,根据该变量在cmp函数中做判断即可。
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    #include <bits/stdc++.h>
    using namespace std;
    struct node {
    int id, score;
    string name;
    };
    int n, c;
    bool cmp(node &a, node &b) {
    if (c == 1) return a.id < b.id;
    else if (c == 2) return a.name != b.name ? a.name < b.name : a.id < b.id;
    else return a.score != b.score ? a.score < b.score : a.id < b.id;
    }
    int main() {
    scanf("%d%d", &n, &c);
    vector<node> stu(n);
    for (int i = 0; i < n; i++) cin >> stu[i].id >> stu[i].name >> stu[i].score;
    sort(stu.begin(), stu.end(), cmp);
    for (auto it : stu) printf("%06d %s %d\n", it.id, it.name.c_str(), it.score);
    return 0;
    }