PAT甲级:A1053 Path of Equal Weight (30分)

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

1
ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID‘s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1,A2,⋯,An} is said to be greater than sequence {B1,B2,⋯,Bm} if there exists 1≤k<min{n,m} such that Ai=Bi for i=1,⋯,k, and Ak+1>Bk+1.

Sample Input:

1
2
3
4
5
6
7
8
9
10
11
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

1
2
3
4
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
  • 题意:给出一棵树,树中每个结点包含编号和权值,编号从 0~N,要求输出从根节点到某一叶子结点路径上各结点的权值(要求这条路径上的权值和等于给定的 W ),如果有多条路径满足条件,则按照降序输出各个路径,例如 a = [10, 5, 2],b = [10, 4, 9],则说 a > b,因为第二项中 5 > 4。
  • 分析:其实考察的就是DFS,每个结点有两个属性,所以定义一个结构体数组,每个元素包含其权值和孩子结点的编号。因为要求降序输出,可以在读入孩子结点的时候就按照其权值降序排序。之后在DFS中传入结点编号 u 与当前权值和 sum 两个属性,如果 sum大于W 或者 sum等于W但当前结点不是叶子结点则退出(剪枝),如果满足条件则直接输出当前路径的权值。另一种方式则是先记录下所有满足条件的路径,之后再一起输出。

方法一:(剪枝回溯)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include <bits/stdc++.h>
using namespace std;
const int N = 110;
struct node {
int weight;
vector<int> child;
} Node[N];
int n, m, w;
vector<int> path;
bool cmp(int a, int b) { return Node[a].weight > Node[b].weight; }
void dfs(int u, int sum) {
if (sum > w) return;
if (sum == w) {
if (Node[u].child.size() != 0) return;
for (int i = 0; i < path.size(); i++) {
if (i != 0) printf(" ");
printf("%d", Node[path[i]].weight);
}
printf("\n");
return;
}
for (auto it : Node[u].child) {
path.push_back(it);
dfs(it, sum + Node[it].weight);
path.pop_back();
}
}
int main() {
scanf("%d%d%d", &n, &m, &w);
for (int i = 0; i < n; i++) scanf("%d", &Node[i].weight);
int parent, child, k;
while (m--) {
scanf("%d%d", &parent, &k);
for (int i = 0; i < k; i++) {
scanf("%d", &child);
Node[parent].child.push_back(child);
}
sort(Node[parent].child.begin(), Node[parent].child.end(), cmp);
}
path.push_back(0);
dfs(0, Node[0].weight);
return 0;
}

方法二:(记录所有结果再行输出)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
#include <bits/stdc++.h>
using namespace std;
const int N = 110;
struct node {
int weight;
vector<int> child;
} Node[N];
int n, m, w;
vector<int> path;
vector<vector<int> > ans;
bool cmp(int a, int b) { return Node[a].weight > Node[b].weight; }
void dfs(int u) {
path.push_back(u);
if (Node[u].child.size() == 0) {
int tempw = 0;
for (auto it : path) tempw += Node[it].weight;
if (tempw == w) ans.push_back(path);
path.pop_back();
return;
}
for (auto it : Node[u].child) dfs(it);
path.pop_back();
}
int main() {
scanf("%d%d%d", &n, &m, &w);
for (int i = 0; i < n; i++) scanf("%d", &Node[i].weight);
int parent, child, k;
while (m--) {
scanf("%d%d", &parent, &k);
for (int i = 0; i < k; i++) {
scanf("%d", &child);
Node[parent].child.push_back(child);
}
sort(Node[parent].child.begin(), Node[parent].child.end(), cmp);
}
dfs(0);
for (int i = 0; i < ans.size(); i++) {
for (int j = 0; j < ans[i].size(); j++) {
if (j != 0) printf(" ");
printf("%d", Node[ans[i][j]].weight);
}
printf("\n");
}
return 0;
}