PAT甲级:A1147 Heaps (30分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

1
2
3
4
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

1
2
3
4
5
6
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10
  • 题意:给出一颗完全二叉树顺序存储的序列,判断这棵树是大顶堆、小顶堆或不是堆,之后输出这完全二叉树的后序遍历序列。
  • 分析:因为是完全二叉树且是顺序存储的方式,所以从下标为1的位置开始依次读入到heap数组中,之后设定isMaxHeapisMinHeap两变量,从下标为2的结点开始,遍历该数组,当前结点编号 i 除以2就是父结点编号,如果孩子结点值大于父结点值则一定不是大顶堆,将isMaxHeap标记为 false,小顶堆同理。最后递归输出后序遍历序列。

注意:输出后序遍历序列最后不能有多余空格,因此设置全局变量cnt判断是否输出空格。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#include <bits/stdc++.h>
using namespace std;
int m, n, cnt = 0, heap[1010];
void postOrder(int i) {
if (i > n) return;
postOrder(i * 2);
postOrder(i * 2 + 1);
printf("%d", heap[i]);
if (++cnt < n) printf(" ");
}
int main() {
scanf("%d%d", &m, &n);
while (m--) {
for (int j = 1; j <= n; j++) scanf("%d", &heap[j]);
bool isMaxHeap = true, isMinHeap = true;
for (int i = 2; i <= n; i++) {
if (heap[i] > heap[i / 2]) isMaxHeap = false;
if (heap[i] < heap[i / 2]) isMinHeap = false;
}
if (!isMaxHeap && !isMinHeap) printf("Not Heap\n");
else printf("%s\n", isMaxHeap ? "Max Heap" : "Min Heap");
cnt = 0;
postOrder(1);
printf("\n");
}
return 0;
}