PTA数据结构与算法题目集:7-14 电话聊天狂人 (25分)

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数N(≤105),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

1
2
3
4
5
4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

输出样例:

1
13588625832 3
  • 题意:找出通话次数最多的人。
  • 分析:map记录每个人的通话次数,变量cntDup表示并列狂人的数量,某人通话次数超过所记录的最大值时cntDup重置为1,否则若有通话次数与最大次数相等则加1。
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
#include <bits/stdc++.h>
using namespace std;
int n, maxCnt = 0, cntDup = 1;
string s, ans = "99999999999";
unordered_map<string, int> hashCnt;
int main() {
scanf("%d", &n);
for (int i = 0; i < n * 2; i++) {
cin >> s;
int cnt = ++hashCnt[s];
if (cnt > maxCnt) {
ans = s;
maxCnt = cnt;
cntDup = 1;
} else if (cnt == maxCnt) {
cntDup++;
if (s < ans) ans = s;
}
}
printf("%s %d", ans.c_str(), maxCnt);
if (cntDup > 1) printf(" %d", cntDup);
return 0;
}