PAT甲级:A1127 ZigZagging on a Tree (30分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

1
2
3
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1
1 11 5 8 17 12 20 15
  • 题意:给一个二叉树的后序和中序遍历序列,要求输出这棵树的 “Z” 字形遍历序列。
  • 分析:这题不需要建树,只用在二叉树中后序序列建树方法的基础上加上depth参数用以记录深度即可,然后通过vector数组依次记录每一层的结点,因为无论前中后遍历二叉树的访问序列都是从上至下从左至右,所以push进vector[层数]同样是按照同一层结点间的顺序的,因此该方式可行,同时在建树方法中记录下出现的最大层数。为了方便记录(其实也差不多),第一层的depth被记为0。
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
#include <bits/stdc++.h>
using namespace std;
const int N = 35;
int post[N], in[N], maxDepth = -1;
vector<int> ans[N];
void create(int postl, int postr, int inl, int inr, int depth) {
if (postl > postr) return;
maxDepth = max(maxDepth, depth);
ans[depth].push_back(post[postr]);
int k = inl;
while (k <= inr && in[k] != post[postr]) k++;
int numleft = k - inl;
create(postl, postl + numleft - 1, inl, k - 1, depth + 1);
create(postl + numleft, postr - 1, k + 1, inr, depth + 1);
}
int main() {
int n;
scanf("%d", &n);
for (int i = 0; i < n; i++) scanf("%d", &in[i]);
for (int i = 0; i < n; i++) scanf("%d", &post[i]);
create(0, n - 1, 0, n - 1, 0);
printf("%d", ans[0][0]);
for (int i = 1; i <= maxDepth; i++) {
if (i % 2 == 0) reverse(ans[i].begin(), ans[i].end());
for (auto it : ans[i]) printf(" %d", it);
}
return 0;
}